当前位置: > 教程分享 > VPS下如何避免WordPress升级需要输入ftp信息的方法

VPS下如何避免WordPress升级需要输入ftp信息的方法

最近小夕在博客搬家之后出现各种各样的问题,wordpress在后台上传模板、升级程序,插件什么的都需要输入ftp信息,本人使用的是VPS。查找了很多原因都终于查出是安装LNMP之后的问题。安装LNMP之后其实很多优化处理都没有结束,特别经常出现在升级插件、Wordpress主程序、以及包括上传图片,都有一堆的权限问题要处理,主要体现在需要输入FTP信息上~而且每次都要输入(感觉心里特别不爽,)网上也有很多人提出修改wp-config.php使其保存FTP密码的方案,但自己还是懒得动那些文件。于是小夕在LNMP的官方论坛上找到了相应的解决方法,希望对大家有用,原理很简单,就是把权限设置给www(这个www是个用户组)

WordPress无法使用自动更新,提示填写FTP信息的解决方法

据LNMP一键安装包使用者反映wordpress提示升级时,点“自动升级”出现填写FTP信息的页面,像我们这些用LNMP的很多都不安装FTP服务器。其实出现这个的问题就是Nginx的执行身份非文件属主身份。

解决方法:

假设你的wordpress安装目录为/home/wwwroot/lnmp.org

用Putty登录Linux VPS,执行

chown -R www /home/wwwroot/lnmp.org

执行上面的命令就可以将/home/wwwroot/lnmp.org下所有文件的属主改为www,这样就可以解决自动更新必须填FTP的问题。

 

网友评论4

  1. 地板
    海南网站建设:

    很久都没有使用这个博客系统了,不知道现在怎么样了.

    2013-11-13 下午 8:59 [回复]
    • 小夕:

      现在使用的人很多哦,最近更新频繁

      2013-11-18 下午 3:19 [回复]
  2. 板凳
    如何减肥:

    受教了

    2013-11-16 下午 4:32 [回复]
  3. 沙发
    indian clothing women:

    Hi there, just wanted to tell you, I enjoyed this post.
    It was funny. Keep on posting!

    2014-04-06 上午 6:24 [回复]

发表评论

表情
还能输入210个字